About This Site

MaxCDN provides transparent updates about our service status. If you are experiencing problems and do not see a notice posted, please contact us.

Email support@maxcdn.com or call +1(877) 629-2361

Live Chat Maintenance
Incident Report for MaxCDN
Resolved
The scheduled maintenance has been completed.
Posted 2 months ago. Oct 03, 2017 - 15:22 UTC
Monitoring
Our vendor is currently undergoing a scheduled maintenance.
Posted 2 months ago. Oct 03, 2017 - 14:08 UTC
This incident affected: Systems (Chat System).