MaxCDN Control Panel Issues
Incident Report for MaxCDN
Resolved
This incident has been resolved.
Posted Jan 16, 2020 - 00:03 UTC
Monitoring
Our engineers have applied a fix and our Control Panel is fully operational. We continue to monitor the situation upon this issues resolution.
Posted Jan 15, 2020 - 22:40 UTC
Investigating
MaxCDN is experiencing issues with the control panel. We are working to resolve the issue and will update as soon as more information is available.

If you have any questions, our Support team is available 24/7 through live chat on https://maxcdn.com/one or through a ticket at support@maxcdn.com
Posted Jan 15, 2020 - 21:57 UTC
This incident affected: Systems (Control Panel).