About This Site

MaxCDN provides transparent updates about our service status. If you are experiencing problems and do not see a notice posted, please contact us.

Email support@maxcdn.com or call +1(877) 629-2361

API
Incident Report for MaxCDN
Resolved
This incident has been resolved.
Posted 2 months ago. Sep 10, 2017 - 21:50 UTC
Investigating
Currently we are investigating the issue.
Posted 2 months ago. Sep 10, 2017 - 21:27 UTC