About This Site

MaxCDN provides transparent updates about our service status. If you are experiencing problems and do not see a notice posted, please contact us.

Email support@maxcdn.com or call +1(877) 629-2361

Issues with the search function on the support site
Incident Report for MaxCDN
Resolved
This incident has been resolved.
Posted 4 months ago. Jul 14, 2017 - 18:55 UTC
Identified
We have discovered an issue with the search function on our support site. Our teams are working on fixing it and we'll update the status page as we progress on mitigating the problem.
Posted 4 months ago. Jul 14, 2017 - 03:40 UTC