About This Site

MaxCDN provides transparent updates about our service status. If you are experiencing problems and do not see a notice posted, please contact us.

Email support@maxcdn.com or call +1(877) 629-2361

Delivery issues with our Frankfurt datacenter
Incident Report for MaxCDN
Resolved
This incident has been resolved.
Posted 17 days ago. Sep 06, 2017 - 19:16 UTC
Monitoring
Our team implemented a fix and will continue monitoring this issue.
Posted 17 days ago. Sep 06, 2017 - 16:43 UTC
Investigating
Our team is currently investigating issues with our Frankfurt server which lead to a short outage for users hitting the server.
Posted 17 days ago. Sep 06, 2017 - 15:10 UTC