MaxCDN Control Panel and API Issues
Incident Report for MaxCDN
Resolved
All systems are fully operational. This incident has been resolved.
Posted Jun 18, 2020 - 02:16 UTC
Monitoring
Our engineers have implemented a fix and we are currently monitoring the results.
Posted Jun 18, 2020 - 01:45 UTC
Investigating
We are currently experiencing issues with the control panel and our API service. We are working to resolve the issue and will update as soon as more information is available.

If you have questions, our Support team is available 24/7 through email at hi@stackpath.com or phone at 1-800-570-2253.
Posted Jun 18, 2020 - 00:28 UTC
This incident affected: Systems (Control Panel, API).