About This Site

MaxCDN provides transparent updates about our service status. If you are experiencing problems and do not see a notice posted, please contact us.

Email support@maxcdn.com or call +1(877) 629-2361

Delivery issues with our Frankfurt datacenter
Incident Report for MaxCDN
Resolved
This issue has been resolved.
Posted 3 months ago. Sep 01, 2017 - 16:58 UTC
Monitoring
Our team implemented a fix and will continue monitoring this issue.
Posted 3 months ago. Sep 01, 2017 - 15:17 UTC
Identified
Our team has identified the issue and we do not expect any additional impact on the clients.
Posted 3 months ago. Sep 01, 2017 - 14:59 UTC
Investigating
Investigating - We're currently experiencing delivery issues with our Frankfurt datacenter and it's being investigated.

Thanks for your patience, if you have any questions feel free to reach out to support@maxcdn.com
Posted 3 months ago. Sep 01, 2017 - 14:52 UTC