Control Panel Problems
Incident Report for MaxCDN
Resolved
This incident has been resolved.
Posted about 1 month ago. Oct 12, 2018 - 00:04 UTC
Update
We are continuing to monitor for any further issues.
Posted about 1 month ago. Oct 11, 2018 - 23:08 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted about 1 month ago. Oct 11, 2018 - 23:03 UTC
Identified
We have identified an issue with our Control Panel, and are working to resolve it now.

If you have any questions, our Support team is available 24/7 through live chat on https://maxcdn.com/one or through a ticket at support@maxcdn.com
Posted about 1 month ago. Oct 11, 2018 - 22:23 UTC
This incident affected: Systems (Control Panel).