Degraded Performance: Control Panel
Incident Report for MaxCDN
Resolved
This incident has been resolved.
Posted Sep 25, 2019 - 00:59 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 24, 2019 - 19:44 UTC
Investigating
We are investigating an issue with the control panel, and are working to resolve it now.

If you have any questions, our Support team is available 24/7 through live chat on https://maxcdn.com/one or through a ticket at support@maxcdn.com
Posted Sep 24, 2019 - 18:32 UTC
This incident affected: Systems (API).