Degraded Performance: Cluster 15 and Shared SSL service
Incident Report for MaxCDN
Resolved
This incident has been resolved.
Posted Mar 06, 2020 - 02:29 UTC
Monitoring
Our engineers have successfully recovered cluster 15 and Shared SSL service is back up. We are closely monitoring their status.
Posted Mar 06, 2020 - 01:50 UTC
Investigating
We are currently experiencing degraded performance for zones on Edge 15 and Shared SSL service. We will update as soon as more information becomes available.

If you have any questions, our Support team is available 24/7 through live chat or through a ticket at support@maxcdn.com
Posted Mar 06, 2020 - 01:02 UTC
This incident affected: North America (New York).