About This Site

MaxCDN provides transparent updates about our service status. If you are experiencing problems and do not see a notice posted, please contact us.

Email support@maxcdn.com or call +1(877) 629-2361

Reporting - Degraded Performance
Incident Report for MaxCDN
Resolved
Our Engineers were successful in resolving the issue. We will continue monitoring the system.
Posted 4 days ago. Oct 12, 2017 - 21:53 UTC
Update
Our Engineers are still working on this issue.
Posted 4 days ago. Oct 12, 2017 - 19:33 UTC
Update
The issue has been identified and a fix is being implemented.
Posted 5 days ago. Oct 12, 2017 - 15:35 UTC
Identified
We are experiencing degraded performance for the reporting section of the StackPath Control Panel.

You may be seeing longer load times when browsing reports. Our engineers are actively working to resolve the issue.
Posted 5 days ago. Oct 12, 2017 - 15:35 UTC
This incident affected: Systems (Control Panel).