Control Panel Issues
Incident Report for MaxCDN
Resolved
This incident has been resolved.
Posted 19 days ago. Feb 01, 2019 - 21:08 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 19 days ago. Feb 01, 2019 - 20:07 UTC
Investigating
MaxCDN is currently experiencing issues with the control panel not responding. We are working to resolve the issue and will update as soon as more information is available.

If you have any questions, our Support team is available 24/7 through live chat on https://www.stackpath.com or through a ticket at support@maxcdn.com
Posted 19 days ago. Feb 01, 2019 - 19:51 UTC
This incident affected: Systems (Control Panel, API).