About This Site

MaxCDN provides transparent updates about our service status. If you are experiencing problems and do not see a notice posted, please contact us.

Email support@maxcdn.com or call +1(877) 629-2361

Degraded Performance: Ticketing/Email Support
Incident Report for MaxCDN
Resolved
This incident has been resolved.
Posted 3 months ago. Mar 16, 2017 - 01:42 UTC
Monitoring
Our ticketing system vendor has resolved the issue on their side and we are monitoring the performance. We will post additional updates as soon as they become available.

If you are experiencing any problems and need to contact us please feel free to contact our Support Team via Live chat: https://www.maxcdn.com/contact/
Posted 3 months ago. Mar 16, 2017 - 00:40 UTC
Investigating
We are currently experiencing issues with third party ticketing/email support platform.
Other means of communication with support - live chat and phone, are still operational.
We apologize for any inconvenience that this issue might cause to timely responding to your inquiries.
We will post updates as soon as they become available.
Posted 3 months ago. Mar 15, 2017 - 19:23 UTC