About This Site

MaxCDN provides transparent updates about our service status. If you are experiencing problems and do not see a notice posted, please contact us.

Email support@maxcdn.com or call +1(877) 629-2361

Traffic rerouted from 3 LAX clusters
Incident Report for MaxCDN
Resolved
The LAX server is back in routing
Posted 17 days ago. Sep 07, 2017 - 03:51 UTC
Identified
The traffic on clusters 16, 21 and 23 has been re-routed from the Los Angeles PoP, which may cause a slight delay in that region. We have identified the issue and are working on resolving it.
Posted 17 days ago. Sep 07, 2017 - 01:30 UTC
Investigating
The traffic on clusters 16, 21 and 23 has been re-routed from the Los Angeles PoP, which may cause a slight delay in that region.
Posted 17 days ago. Sep 07, 2017 - 00:58 UTC