About This Site

MaxCDN provides transparent updates about our service status. If you are experiencing problems and do not see a notice posted, please contact us.

Email support@maxcdn.com or call +1(877) 629-2361

Real Time Reporting
Incident Report for MaxCDN
Resolved
This incident has been resolved.
Posted 22 days ago. Sep 01, 2017 - 06:48 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 23 days ago. Sep 01, 2017 - 05:28 UTC
Identified
We have located the issue with Real Time Reporting, and are working on resolving the issue.
Posted 23 days ago. Aug 31, 2017 - 23:41 UTC
Investigating
We are currently investigating issues with Real Time Reporting.
Posted 23 days ago. Aug 31, 2017 - 22:06 UTC