Maintenance Tel Aviv PoP
Incident Report for MaxCDN
Resolved
This incident has been resolved.
Posted about 1 month ago. Nov 01, 2018 - 10:16 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted about 1 month ago. Oct 30, 2018 - 11:19 UTC
Investigating
Scheduled maintenance is currently in progress. All requests coming to our Flex location in Tel Aviv will be routed to nearest CDN server while maintenance lasts.

If you have any questions freely reach out to us over support@maxcdn.com at any moment.
Posted about 1 month ago. Oct 30, 2018 - 10:13 UTC