About This Site

MaxCDN provides transparent updates about our service status. If you are experiencing problems and do not see a notice posted, please contact us.

Email support@maxcdn.com or call +1(877) 629-2361

Ticketing System - Degraded Performance
Incident Report for MaxCDN
Resolved
This incident has been resolved.
Posted 2 months ago. Sep 09, 2017 - 22:14 UTC
Monitoring
The ticketing system vendor is experiencing degraded performance in some regions. We are carefully monitoring the situation.

In case you are unable to Submit a ticket over Email, please reach out to us, over Live Chat or phone.
https://www.stackpath.com/contact/
Posted 2 months ago. Sep 09, 2017 - 19:06 UTC