Degraded Performance: Seattle PoP
Incident Report for MaxCDN
Resolved
This incident has been resolved.
Posted 3 months ago. Sep 19, 2018 - 00:45 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 3 months ago. Sep 18, 2018 - 22:15 UTC
Investigating
We are currently experiencing degraded performance and provisioning issues on our Seattle PoP. We will update our status page as soon as more information becomes available.

If you have any questions, our Support team is available 24/7 through live chat on https://maxcdn.com/one or through a ticket at support@maxcdn.com
Posted 3 months ago. Sep 18, 2018 - 20:31 UTC