About This Site

MaxCDN provides transparent updates about our service status. If you are experiencing problems and do not see a notice posted, please contact us.

Email support@maxcdn.com or call +1(877) 629-2361

Live chat issues
Incident Report for MaxCDN
Resolved
This incident has been resolved.
Posted 4 months ago. Apr 20, 2017 - 14:56 UTC
Monitoring
Live chat is up again. Our team continues with monitoring.
Posted 4 months ago. Apr 20, 2017 - 13:49 UTC
Investigating
We are having technical difficulties with our live chat system.

Please contact our support via ticketing system.
Posted 4 months ago. Apr 20, 2017 - 13:47 UTC