Live chat issues
Incident Report for MaxCDN
Resolved
This incident has been resolved.
Posted 4 months ago. May 05, 2019 - 03:31 UTC
Monitoring
Our live chat support system is now working properly. We are closely monitoring it.
Posted 4 months ago. May 05, 2019 - 02:32 UTC
Investigating
MaxCDN is experiencing issues with our live chat support system. Please contact our support via ticketing system or over phone number +1 (323) 313-1206.
Posted 4 months ago. May 05, 2019 - 01:31 UTC
This incident affected: Systems (Chat System).