Control Panel Unavailable
Incident Report for MaxCDN
Resolved
This incident has been resolved.
Posted Nov 13, 2019 - 19:52 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 13, 2019 - 19:09 UTC
Investigating
MaxCDN is currently experiencing issues with the control panel. We are working to resolve the issue and will update as soon as more information is available.

If you have any questions, our Support team is available 24/7 through live chat on https://maxcdn.com/one or through a ticket at support@maxcdn.com
Posted Nov 13, 2019 - 17:20 UTC
This incident affected: Systems (Control Panel).