About This Site

MaxCDN provides transparent updates about our service status. If you are experiencing problems and do not see a notice posted, please contact us.

Email support@maxcdn.com or call +1(877) 629-2361

DNS propagation issues
Incident Report for MaxCDN
Resolved
The issue was resolved on our DNS provider's side and we are seeing optimal performance again.
Posted 7 months ago. Mar 15, 2017 - 01:41 UTC
Investigating
We are experiencing intermittent provisioning issues which are caused by a problem with our DNS provider. This issue might affect customers who are trying to create new sites. For assistance please contact our 24/7/365 support at: https://www.maxcdn.com/contact/
Posted 7 months ago. Mar 14, 2017 - 01:54 UTC