Degraded Performance: edge15, edge23, and purge service disruption
Incident Report for MaxCDN
Resolved
This incident has been resolved.
Posted about 1 month ago. May 15, 2019 - 03:27 UTC
Monitoring
Our engineers have successfully recovered our clusters and we are closely monitoring their status.
Posted about 1 month ago. May 15, 2019 - 01:06 UTC
Update
Our Engineers are still working to recover our clusters with all efforts. We will keep posting further updates as we have them.
Posted about 1 month ago. May 14, 2019 - 23:20 UTC
Identified
We have identified the problem and our engineered are recovering the edges in different locations at the moment. We will update you as soon as all of them are back online.
Posted about 1 month ago. May 14, 2019 - 21:44 UTC
Update
We are continuing to investigate this issue.
Posted about 1 month ago. May 14, 2019 - 20:54 UTC
Update
We are continuing to investigate this issue.
Posted about 1 month ago. May 14, 2019 - 20:51 UTC
Investigating
We are currently experiencing degraded performance, purge delays, and provisioning issues in all PoPs for Edge 15 and Edge 23. We will update as soon as more information becomes available.

If you have any questions, our Support team is available 24/7 through live chat or through a ticket at support@maxcdn.com.
Posted about 1 month ago. May 14, 2019 - 20:49 UTC
This incident affected: Systems (Purge).