About This Site

MaxCDN provides transparent updates about our service status. If you are experiencing problems and do not see a notice posted, please contact us.

Email support@maxcdn.com or call +1(877) 629-2361

Degraded Performance: Intermittent provisioning issues
Incident Report for MaxCDN
Resolved
This incident has been resolved.
Posted 2 months ago. Apr 19, 2017 - 12:33 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 2 months ago. Apr 19, 2017 - 11:52 UTC
Investigating
We are currently experiencing issues with our provisioning system. Our team is working on resolving the issue.

If you have any questions please contact our Speed Team https://www.maxcdn.com/contact/
Posted 2 months ago. Apr 19, 2017 - 11:38 UTC
This incident affected: North America (Virginia).