Billing Provider Maintenance
Incident Report for MaxCDN
Resolved
This incident has been resolved.
Posted 15 days ago. Jan 01, 2019 - 13:32 UTC
Investigating
Our billing provider will be performing critical maintenance for three hours starting at 05:00 UTC. During this time, customers will be unable to make changes to services, including cancelling or adding them. For help with these items, please contact our support team and we will manually complete these tasks for you after maintenance is concluded. Thank you for your patience.
Posted about 1 month ago. Dec 13, 2018 - 04:34 UTC