Control Panel timeout issues
Incident Report for MaxCDN
Resolved
This incident has been resolved.
Posted Sep 13, 2019 - 19:58 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 13, 2019 - 18:07 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 13, 2019 - 17:14 UTC
Investigating
We have currently identified timeout issues on the account control panel.

We apologize for any inconvenience that this issue might cause to timely responding to your inquiries. We will post updates as soon as they become available.

If you have questions, our Support team is available 24/7 over phone at 1-800-570-2253.
Posted Sep 13, 2019 - 16:36 UTC
This incident affected: Systems (Control Panel).