Degraded Performance in cluster 22 North-East US & Europe.
Incident Report for MaxCDN
Resolved
This incident has been resolved.

If you have any questions, our Support team is available 24/7 through live chat on https://maxcdn.com/one or through a ticket at support@maxcdn.com
Posted Oct 18, 2021 - 19:15 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 18, 2021 - 18:13 UTC
Update
We are continuing to investigate this issue.
Posted Oct 18, 2021 - 16:07 UTC
Investigating
We are currently experiencing degraded performance and provisioning issues on cluster 22 in the North-East US and Europe regions . We will update our status page as soon as more information becomes available.

If you have any questions, our Support team is available 24/7 through live chat on https://maxcdn.com/one or through a ticket at support@maxcdn.com
Posted Oct 18, 2021 - 16:06 UTC
This incident affected: Europe (Paris, London) and North America (New York).