Degraded Performance: Control Panel
Incident Report for MaxCDN
Resolved
This incident has been resolved.
Posted Oct 26, 2019 - 00:04 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 25, 2019 - 21:57 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 25, 2019 - 21:38 UTC
Investigating
We are investigating issue with Maxcdn Portal and are working to resolve it now.

If you have any questions, our Support team is available 24/7 through live chat on https://maxcdn.com/one or through a ticket at support@maxcdn.com
Posted Oct 25, 2019 - 21:25 UTC
This incident affected: Systems (Control Panel).