SSLv3 Support Disabled
Incident Report for MaxCDN
Resolved
There is a vulnerability in the current version of SSLv3 (CVE­-2014-­3566). We have disabled SSLv3 support across our network to prevent possible decryption of SSL sessions. This will affect users running older browsers and will result in a SSL connection error. The largest impact will be users of Internet Explorer 6 on Windows XP or older systems.
Posted almost 5 years ago. Oct 15, 2014 - 00:54 UTC