MaxCDN Control Panel issues
Incident Report for MaxCDN
Resolved
The incident has been resolved.
Posted Nov 14, 2019 - 04:52 UTC
Monitoring
After fix was implemented by our engineers, all services have been restored to normal operation. We will continue to monitor performance of both Control Panel and API.
Posted Nov 13, 2019 - 23:52 UTC
Identified
The issue has been identified and we are working on implementing a fix. We will update the Status Page as further information is available.

If you have any questions, our Support team is available 24/7 through live chat on https://maxcdn.com/one or through a ticket at support@maxcdn.com
Posted Nov 13, 2019 - 22:25 UTC
Investigating
MaxCDN is currently experiencing issues with the control panel. We are working to resolve the issue and will update as soon as more information is available.

If you have any questions, our Support team is available 24/7 through live chat on https://maxcdn.com/one or through a ticket at support@maxcdn.com
Posted Nov 13, 2019 - 21:20 UTC
This incident affected: Systems (Control Panel, API).