Billing details not showing up
Incident Report for MaxCDN
Resolved
This incident has been resolved.
Posted Apr 24, 2020 - 10:21 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 24, 2020 - 09:48 UTC
Identified
We are experiencing an issue where invoices are not showing up in our control panel. Engineers have identified the issue and are working toward solving it.
Posted Apr 24, 2020 - 08:56 UTC
This incident affected: Systems (Billing).