Degraded Performance in Control Panel
Incident Report for MaxCDN
Resolved
This incident has been resolved.
Posted 5 days ago. Dec 06, 2018 - 17:38 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 5 days ago. Dec 06, 2018 - 14:35 UTC
Investigating
We are currently investigating degraded performance in our Control Panel . We will provide updates as they become available.

If you have any additional questions you can reach out to support via live chat or ticketing system.
Posted 5 days ago. Dec 06, 2018 - 14:29 UTC
This incident affected: Systems (Control Panel).