About This Site

MaxCDN provides transparent updates about our service status. If you are experiencing problems and do not see a notice posted, please contact us.

Email support@maxcdn.com or call +1(877) 629-2361

Dedicated, SNI Certificate Global Sign issue
Incident Report for MaxCDN
Resolved
This incident has been resolved.
Posted 7 months ago. May 16, 2017 - 22:12 UTC
Identified
We're experiencing issues with the purchase and renewal of SSL Certificates through our Dedicated SSL and SNI options.
Our team is closely working with the vendor to resolve the issue as quickly as possible.

Thank you for your understanding.

If you have any questions please contact our support team: https://www.maxcdn.com/contact
Posted 7 months ago. May 16, 2017 - 19:27 UTC